$re = '/(?!.*Rejected.*)RC:\*.*?(?P<Capture>(Bob|David|Ted|Alice)).*/';
$str = 'RC:* Hi Bob Smith<\\person>
RC:* Hi David Jones *Notes Bla bla<\\person>
RC:* Hi Ted Warren *Rejected <\\person>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);