package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(Test\d)_([A-Za-z0-9]+)(?:_([A-Za-z0-9]+))?`)
var str = `Test1_MYSTRING_val1
Test1_MYSTRING`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}