$re = '/(Test\d)_([A-Za-z0-9]+)(?:_([A-Za-z0-9]+))?/';
$str = 'Test1_MYSTRING_val1
Test1_MYSTRING';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);