re = /(Test\d)_([A-Za-z0-9]+)(?:_([A-Za-z0-9]+))?/
str = 'Test1_MYSTRING_val1
Test1_MYSTRING'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end