using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=([\.]{1}[a-zA-Z_]+[\w\_\-]*)[\s\.\+\{\>#\:]{1})";
string input = @".aClass.foo.bar .qwerty {
border-bottom: 1px solid color.get('primary');
padding: .5em;
background-color: color.get('background');
.foo>.bar {
background-image: url(""paper.gif"");
}
.aCamelCaseClass {
}
#anIdThatShouldNotBeMatched {
}
.foo > .bar {
background-image: url(""paper.gif"");
}
.qwe+.rew>.qwe{ }
.qwe:hover
{
}
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}