use strict;
my $str = '.aClass.foo.bar .qwerty {
border-bottom: 1px solid color.get(\'primary\');
padding: .5em;
background-color: color.get(\'background\');
.foo>.bar {
background-image: url("paper.gif");
}
.aCamelCaseClass {
}
#anIdThatShouldNotBeMatched {
}
.foo > .bar {
background-image: url("paper.gif");
}
.qwe+.rew>.qwe{ }
.qwe:hover
{
}
}';
my $regex = qr/(?=([\.]{1}[a-zA-Z_]+[\w\_\-]*)[\s\.\+\{\>#\:]{1})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}