import re
regex = re.compile(r"(?=([\.]{1}[a-zA-Z_]+[\w\_\-]*)[\s\.\+\{\>#\:]{1})", flags=re.MULTILINE)
test_str = (".aClass.foo.bar .qwerty {\n"
" border-bottom: 1px solid color.get('primary');\n"
" padding: .5em;\n"
" background-color: color.get('background');\n"
" \n"
" .foo>.bar {\n"
" background-image: url(\"paper.gif\");\n"
" } \n"
" \n"
" .aCamelCaseClass {\n\n"
" }\n\n"
" #anIdThatShouldNotBeMatched {\n"
" }\n\n"
" .foo > .bar {\n"
" background-image: url(\"paper.gif\");\n"
" } \n"
" \n"
" .qwe+.rew>.qwe{ }\n\n"
" .qwe:hover\n"
" {\n"
" }\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")