#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "_([a-z]{2}[0-9]{3})[_.]"
Local $sString = "mf_lp_gn817_ml46 d_nb_05340.gif gn817" & @CRLF & _
"desktop_300x250_mf mf_lp_fb824_ml46.html fb824" & @CRLF & _
"desktop_300x250_mf dd_lp_ig805.html ig805" & @CRLF & _
"desktop_728x90_mf mf_lp_fb824_ml46.html fb824"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")