package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`_([a-z]{2}[0-9]{3})[_.]`)
var str = `mf_lp_gn817_ml46 d_nb_05340.gif gn817
desktop_300x250_mf mf_lp_fb824_ml46.html fb824
desktop_300x250_mf dd_lp_ig805.html ig805
desktop_728x90_mf mf_lp_fb824_ml46.html fb824`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}