# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"_([a-z]{2}[0-9]{3})[_.]"
test_str = ("mf_lp_gn817_ml46 d_nb_05340.gif gn817\n"
"desktop_300x250_mf mf_lp_fb824_ml46.html fb824\n"
"desktop_300x250_mf dd_lp_ig805.html ig805\n"
"desktop_728x90_mf mf_lp_fb824_ml46.html fb824")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.