use strict;
my $str = 'mf_lp_gn817_ml46 d_nb_05340.gif gn817
desktop_300x250_mf mf_lp_fb824_ml46.html fb824
desktop_300x250_mf dd_lp_ig805.html ig805
desktop_728x90_mf mf_lp_fb824_ml46.html fb824';
my $regex = qr/_([a-z]{2}[0-9]{3})[_.]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}