#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=\\f[ ](?P<modifier>[-,+,?])[ ])(?P<string>.+)(?=\\f\*)"
Local $sString = "\f + \fr 1.1: \ft Some manuscripts do not have \fq the Son of God.\f*" & @CRLF & _
"\f + \fr 1.4: \fq John appeared in the desert, baptizing and preaching; \ft some manuscripts have \fqa John the Baptist appeared in the desert, preaching.\f*"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")