$re = '/(?<=\\\\f[ ](?P<modifier>[-,+,?])[ ])(?P<string>.+)(?=\\\\f\*)/';
$str = '\\f + \\fr 1.1: \\ft Some manuscripts do not have \\fq the Son of God.\\f*
\\f + \\fr 1.4: \\fq John appeared in the desert, baptizing and preaching; \\ft some manuscripts have \\fqa John the Baptist appeared in the desert, preaching.\\f*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);