using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\\f[ ](?P<modifier>[-,+,?])[ ])(?P<string>.+)(?=\\f\*)";
string input = @"\f + \fr 1.1: \ft Some manuscripts do not have \fq the Son of God.\f*
\f + \fr 1.4: \fq John appeared in the desert, baptizing and preaching; \ft some manuscripts have \fqa John the Baptist appeared in the desert, preaching.\f*";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}