import Foundation
let pattern = #"(?<=\\f[ ](?P<modifier>[-,+,?])[ ])(?P<string>.+)(?=\\f\*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
\f + \fr 1.1: \ft Some manuscripts do not have \fq the Son of God.\f*
\f + \fr 1.4: \fq John appeared in the desert, baptizing and preaching; \ft some manuscripts have \fqa John the Baptist appeared in the desert, preaching.\f*
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)