using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a ?.*? href=""(?:(?:.*?example\.com.*?)|(?:[^\.]*?))"".*?>(.*?)<\/a>";
string substitution = @"$1";
string input = @"<a href=""https://example.com/page_url"" data-some-id="" data-other-prop="">Link 1</a>
<a data-href="" href=""http://Go to page"" data-another-id="">Link 2</a>
<a data-other="" href=""/Go to page"" data-val-id="">Link 3</a>
<a href=""http://example123.com/page"" data-props-id="">Link 4</a>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}