# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<a ?.*? href=\"(?:(?:.*?example\.com.*?)|(?:[^\.]*?))\".*?>(.*?)<\/a>"
test_str = ("<a href=\"https://example.com/page_url\" data-some-id=\"\" data-other-prop=\"\">Link 1</a>\n"
"<a data-href=\"\" href=\"http://Go to page\" data-another-id=\"\">Link 2</a>\n"
"<a data-other=\"\" href=\"/Go to page\" data-val-id=\"\">Link 3</a>\n"
"<a href=\"http://example123.com/page\" data-props-id=\"\">Link 4</a>")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.