// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<a ?.*? href="(?:(?:.*?example\.com.*?)|(?:[^\.]*?))".*?>(.*?)<\/a>"#).unwrap();
let string = "<a href=\"https://example.com/page_url\" data-some-id=\"\" data-other-prop=\"\">Link 1</a>
<a data-href=\"\" href=\"http://Go to page\" data-another-id=\"\">Link 2</a>
<a data-other=\"\" href=\"/Go to page\" data-val-id=\"\">Link 3</a>
<a href=\"http://example123.com/page\" data-props-id=\"\">Link 4</a>";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}