const regex = /<a ?.*? href="(?:(?:.*?example\.com.*?)|(?:[^\.]*?))".*?>(.*?)<\/a>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a ?.*? href="(?:(?:.*?example\\.com.*?)|(?:[^\\.]*?))".*?>(.*?)<\\\/a>', 'gm')
const str = `<a href="https://example.com/page_url" data-some-id="" data-other-prop="">Link 1</a>
<a data-href="" href="http://Go to page" data-another-id="">Link 2</a>
<a data-other="" href="/Go to page" data-val-id="">Link 3</a>
<a href="http://example123.com/page" data-props-id="">Link 4</a>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);