using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http|https):\/\/(www\.)*youtube\.com\/.*";
string input = @"https://www.youtube.com/watch?v=vP1PeXHba64";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}