$re = '/(http|https):\/\/(www\.)*youtube\.com\/.*/';
$str = 'https://www.youtube.com/watch?v=vP1PeXHba64';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);