const regex = /(http|https):\/\/(www\.)*youtube\.com\/.*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http|https):\\\/\\\/(www\\.)*youtube\\.com\\\/.*', '')
const str = `https://www.youtube.com/watch?v=vP1PeXHba64`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}