re = /(http|https):\/\/(www\.)*youtube\.com\/.*/
str = 'https://www.youtube.com/watch?v=vP1PeXHba64'
# Print the match result
str.match(re) do |match|
puts match.to_s
end