import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(0-9]{5,6}[\\t|\\s]+sl-SI)[\\r\\n]";
final String string = "Hello team,\n\n"
+ "We have dispatched a new job for you in GlobalLink.\n"
+ "Please see details below and kindly check the instructions field for each submission before you start working on it, as there could be special instructions in GL added by the client.\n\n"
+ "Translation task Deadline: please check in Junction task\n"
+ "Copy Edit task Deadline: please check in Junction task\n"
+ "Job Names **\n"
+ "Sub ID Lang\n"
+ "151097 sl-SI\n"
+ "151096 sr-RS\n"
+ "151094 da-DK\n"
+ "151093 tr-TR\n"
+ "151417 pt-BR\n\n";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}