// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(0-9]{5,6}[\t|\s]+sl-SI)[\r\n]").unwrap();
let string = "Hello team,
We have dispatched a new job for you in GlobalLink.
Please see details below and kindly check the instructions field for each submission before you start working on it, as there could be special instructions in GL added by the client.
Translation task Deadline: please check in Junction task
Copy Edit task Deadline: please check in Junction task
Job Names **
Sub ID Lang
151097 sl-SI
151096 sr-RS
151094 da-DK
151093 tr-TR
151417 pt-BR
";
let substitution = "\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}