# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(0-9]{5,6}[\t|\s]+sl-SI)[\r\n]"
test_str = ("Hello team,\n\n"
"We have dispatched a new job for you in GlobalLink.\n"
"Please see details below and kindly check the instructions field for each submission before you start working on it, as there could be special instructions in GL added by the client.\n\n"
"Translation task Deadline: please check in Junction task\n"
"Copy Edit task Deadline: please check in Junction task\n"
"Job Names **\n"
"Sub ID Lang\n"
"151097 sl-SI\n"
"151096 sr-RS\n"
"151094 da-DK\n"
"151093 tr-TR\n"
"151417 pt-BR\n\n")
subst = "\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.