#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?si)<div[^>]*>.*<\/div>"
Local $sString = "<div id="my_id"> bla bla" & @CRLF & _
" <div>" & @CRLF & _
" bla bla bla" & @CRLF & _
" <div style="some style here">" & @CRLF & _
" lalalalala" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
" I'm trapped in a div!" & @CRLF & _
"</div>" & @CRLF & _
"more text outside divs" & @CRLF & _
"" & @CRLF & _
"<div>more divs here!" & @CRLF & _
" <div id="justbeingannoying">radiohead rules</div>" & @CRLF & _
"</div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")