package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?si)<div[^>]*>.*<\/div>`)
var str = `<div id="my_id"> bla bla
<div>
bla bla bla
<div style="some style here">
lalalalala
</div>
</div>
I'm trapped in a div!
</div>
more text outside divs
<div>more divs here!
<div id="justbeingannoying">radiohead rules</div>
</div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}