import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div[^>]*>.*<\\/div>";
final String string = "<div id=\"my_id\"> bla bla\n"
+ " <div>\n"
+ " bla bla bla\n"
+ " <div style=\"some style here\">\n"
+ " lalalalala\n"
+ " </div>\n"
+ " </div>\n"
+ " I'm trapped in a div!\n"
+ "</div>\n"
+ "more text outside divs\n\n"
+ "<div>more divs here!\n"
+ " <div id=\"justbeingannoying\">radiohead rules</div>\n"
+ "</div>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}