# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<div[^>]*>.*<\/div>"
test_str = ("<div id=\"my_id\"> bla bla\n"
" <div>\n"
" bla bla bla\n"
" <div style=\"some style here\">\n"
" lalalalala\n"
" </div>\n"
" </div>\n"
" I'm trapped in a div!\n"
"</div>\n"
"more text outside divs\n\n"
"<div>more divs here!\n"
" <div id=\"justbeingannoying\">radiohead rules</div>\n"
"</div>")
matches = re.finditer(regex, test_str, re.DOTALL | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.