#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(text1).*(text2)|\2.*\1"
Local $sString = "text0 asdf asdf asdf" & @CRLF & _
"asdf asdf text1 asdf" & @CRLF & _
"asdf text2 asdf" & @CRLF & _
"asdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")