$re = '/(text1).*(text2)|\2.*\1/s';
$str = 'text0 asdf asdf asdf
asdf asdf text1 asdf
asdf text2 asdf
asdf';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);