const regex = /(text1).*(text2)|\2.*\1/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(text1).*(text2)|\\2.*\\1', 's')
const str = `text0 asdf asdf asdf
asdf asdf text1 asdf
asdf text2 asdf
asdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}