using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(text1).*(text2)|\2.*\1";
string input = @"text0 asdf asdf asdf
asdf asdf text1 asdf
asdf text2 asdf
asdf";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}