const regex = /(text1)[\s\S]*(text2)|\2[\s\S]*\1/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(text1)[\\s\\S]*(text2)|\\2[\\s\\S]*\\1', '')
const str = `text0 asdf asdf asdf
asdf asdf text1 asdf
asdf text2 asdf
asdf`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}