re = /(text1)[\s\S]*(text2)|\2[\s\S]*\1/
str = 'text0 asdf asdf asdf
asdf asdf text1 asdf
asdf text2 asdf
asdf'
# Print the match result
str.match(re) do |match|
puts match.to_s
end