import Foundation
let pattern = #"(text1)[\s\S]*(text2)|\2[\s\S]*\1"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
text0 asdf asdf asdf
asdf asdf text1 asdf
asdf text2 asdf
asdf
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}