package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^.{0,59}(?:\r?\n.{0,59}){0,4}$`)
var str = `1234567890
12345678901234567890
123456789012345678901234567890
1234567890123456789012345678901234567890
12345678901234567890123456789012345678901234567890`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}