const regex = /^.{0,59}(?:\r?\n.{0,59}){0,4}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.{0,59}(?:\\r?\\n.{0,59}){0,4}$', '')
const str = `1234567890
12345678901234567890
123456789012345678901234567890
1234567890123456789012345678901234567890
12345678901234567890123456789012345678901234567890`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}