use strict;
my $str = '1234567890
12345678901234567890
123456789012345678901234567890
1234567890123456789012345678901234567890
12345678901234567890123456789012345678901234567890';
my $regex = qr/^.{0,59}(?:\r?\n.{0,59}){0,4}$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}