import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "( xmlns:?[^=]*=[\"\"][^\"\"]*[\"\"])";
final String string = "<?xml version=\"1.0\" encoding=\"utf-8\"?>\n"
+ "<soap:Envelope xmlns:soap=\"http://schemas.xmlsoap.org/soap/envelope/\" xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\" xmlns:xsd=\"http://www.w3.org/2001/XMLSchema\">\n"
+ " <soap:Body>\n"
+ " <ConnectResponse xmlns=\"aa\">\n"
+ " <ConnectResult xmlns=\"bb\">\n"
+ " <RETURNS>\n"
+ " <STATUS>A92A7EBEE897499fA8B06D5FE94B8A30</STATUS>\n"
+ " <APIPAYLOAD>\n"
+ " <COMMAND>\n"
+ " <TRACKINGID mya=\"cc\">e3d1618b4b7847628b10d4a432ec9151</TRACKINGID>\n"
+ " </COMMAND>\n"
+ " </APIPAYLOAD>\n"
+ " </RETURNS>\n"
+ " </ConnectResult>\n"
+ " </ConnectResponse>\n"
+ " </soap:Body>\n"
+ "</soap:Envelope>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}