import re
regex = re.compile(r"( xmlns:?[^=]*=[\"\"][^\"\"]*[\"\"])")
test_str = ("<?xml version=\"1.0\" encoding=\"utf-8\"?>\n"
"<soap:Envelope xmlns:soap=\"http://schemas.xmlsoap.org/soap/envelope/\" xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\" xmlns:xsd=\"http://www.w3.org/2001/XMLSchema\">\n"
" <soap:Body>\n"
" <ConnectResponse xmlns=\"aa\">\n"
" <ConnectResult xmlns=\"bb\">\n"
" <RETURNS>\n"
" <STATUS>A92A7EBEE897499fA8B06D5FE94B8A30</STATUS>\n"
" <APIPAYLOAD>\n"
" <COMMAND>\n"
" <TRACKINGID mya=\"cc\">e3d1618b4b7847628b10d4a432ec9151</TRACKINGID>\n"
" </COMMAND>\n"
" </APIPAYLOAD>\n"
" </RETURNS>\n"
" </ConnectResult>\n"
" </ConnectResponse>\n"
" </soap:Body>\n"
"</soap:Envelope>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")