// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
  let regex = Regex::new(r#"( xmlns:?[^=]*=[""][^""]*[""])"#).unwrap();
  let string = "<?xml version=\"1.0\" encoding=\"utf-8\"?>
<soap:Envelope xmlns:soap=\"http://schemas.xmlsoap.org/soap/envelope/\" xmlns:xsi=\"http://www.w3.org/2001/XMLSchema-instance\" xmlns:xsd=\"http://www.w3.org/2001/XMLSchema\">
  <soap:Body>
    <ConnectResponse xmlns=\"aa\">
      <ConnectResult xmlns=\"bb\">
        <RETURNS>
          <STATUS>A92A7EBEE897499fA8B06D5FE94B8A30</STATUS>
          <APIPAYLOAD>
            <COMMAND>
              <TRACKINGID mya=\"cc\">e3d1618b4b7847628b10d4a432ec9151</TRACKINGID>
            </COMMAND>
          </APIPAYLOAD>
        </RETURNS>
      </ConnectResult>
    </ConnectResponse>
  </soap:Body>
</soap:Envelope>";
  
  // result will be an iterator over tuples containing the start and end indices for each match in the string
  let result = regex.captures_iter(string);
  
  for mat in result {
    println!("{:?}", mat);
  }
}