$re = '/\d\.\d\.\d/';
$str = '"search-components@1.1.1"
"e2bf8da9-275a-484d-95a6-7e6b8c0ce0ca"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);