import re
regex = re.compile(r"\d\.\d\.\d")
test_str = ("\"search-components@1.1.1\"\n"
"\"e2bf8da9-275a-484d-95a6-7e6b8c0ce0ca\"")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")