// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\d\.\d\.\d").unwrap();
let string = "\"search-components@1.1.1\"
\"e2bf8da9-275a-484d-95a6-7e6b8c0ce0ca\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}