re = /\d\.\d\.\d/
str = '"search-components@1.1.1"
"e2bf8da9-275a-484d-95a6-7e6b8c0ce0ca"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end