import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![^0\\n]*0[^0\\n]*(?:0[^0\\n]*0)*[^0\\n]*$)(?![^1\\n]*1[^1\\n]*(?:1[^1\\n]*1)*[^1\\n]*$)[10]*$";
final String string = "100001\n"
+ "10001\n"
+ "1\n"
+ "11\n"
+ "00\n"
+ "1001\n"
+ "0101\n"
+ "011\n"
+ "101\n"
+ "1010";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}