const regex = /^(?![^0\n]*0[^0\n]*(?:0[^0\n]*0)*[^0\n]*$)(?![^1\n]*1[^1\n]*(?:1[^1\n]*1)*[^1\n]*$)[10]*$/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?![^0\\n]*0[^0\\n]*(?:0[^0\\n]*0)*[^0\\n]*$)(?![^1\\n]*1[^1\\n]*(?:1[^1\\n]*1)*[^1\\n]*$)[10]*$', 'igm')
const str = `100001
10001
1
11
00
1001
0101
011
101
1010`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}