$re = '/^(?![^0\n]*0[^0\n]*(?:0[^0\n]*0)*[^0\n]*$)(?![^1\n]*1[^1\n]*(?:1[^1\n]*1)*[^1\n]*$)[10]*$/im';
$str = '100001
10001
1
11
00
1001
0101
011
101
1010';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);